MT4 is mad at me I think

hey folks…
I entered a demo trade into the oanda platform last night.
Very easy to do.

I tried to enter the same trade (volume was rounded off though) into MT4.
It’s setup through an Alpari demo account.
MT4 failed to enert the trade and told me something was invlaid about my stop or target values.

I used the exact same numbers that worked just fine in Oanda.

ANyone else see this type of behavior before?
Did I forget to ask MT4 nicely or something?

Thanks!

Was it a pending order or a market order?

Also you’re stop loss may have been too tight (with IBFX you can’t place a SL within 3pips of your entry price)

It was a pending sell limit order.
The stop was 56 pips and the target was 74.3 pips

(a weird trade I know - but was just playing with the ordering interface. I’m hoping to start demoing seriously tonight)

Check your spread. I never used alpari, but when I was with another broker in a demo account that had something ridiculous like 24 pip spread for exotics, the stop loss was too small to cover the spread.

Are you sure you’re not confusing you’re sell limit and sell stop orders.

Have a glance at this:

New to Market - MetaTrader User Guide - Pending Orders - Alpari (UK)

Thanks ReaperKK!
I award you 1,000 cool points. :slight_smile:
I guess the word “stop” threw me on the “Sell Stop” order.