MT4 Toolbar

Hi all,

i’m new to using MT4 and my question is how do i dock the periodicity and charts toolbar back to the platform? i accidentally clicked on the ‘lines’ which appeared on both toolbars before they were ‘de-docked’.

An example of the ‘lines’ would be those next to the mouse pointer of the Lines Studies toolbar, as seen in the attached image.

can some kind souls help me out?

i’m using MT4 on a mac, if this info is helpful

much appreciated and thanks!


you just drag each one beside the other toolbars (those you see on the left of your image).
you can also dock them anywhere within the platform (vertically or horizontally) or outside the MT4 platform perimeter, if you so wish.
that’s how I do it in Windows. try it on your Mac.

hi Fring, thanks for the response

so after dragging them to beside of those toolbars on left of image how do i dock them? double-clicking them?

you just drag them and they will automatically dock. they can have spaces in between, so you may need to make some extra adjustments (just drag as you see fit)

I hope I am making myself clear, otherwise just let me know.

i kept dragging around the area next to those left toolbars but they still aren’t docked. is it because it’s an MT4 on mac?

If there is a ‘minimise’ icon on the tab, then try clicking that? it may lodge it back in the MT4 tool bar.

hi jezz, i can’t minimize it, the option isn’t available on taskbar of toolbars. the only operation i can perform is the cross to cancel the toolbar function

that’s strange. have you tried any thing else?
can you try undocking those toolbars on the left?

I did this one too a few days ago by accident, pulled a toolbar out as a separate window. I also use MT4 on a Mac. I didn’t have any luck either. Absolutely nothing I did would get it to meld back into the chart. I don’t know if this is a Windows-on-a-Mac issue, or if it has more to do with the software it takes to get MT4 to run on a Mac, or what it is. I ended up redownloading MT4 and starting over. It’s a brute force solution, but nothing else worked. If someone has an easier way, I’d love to hear it.

I am presently having this same issue. Does anybody know how to fix it without having to completely reinstall the MT4 software?

Still no solution for this??

Can you, in a worst case scenario, uninstall and then reinstall your platform? That’s what I do when nothing else works.

I found out another solution.I replaced terminal.ini with the original file or the other MT4’s,if you have installed few,fixed my problem.It will replace lot of things so please check and back up the file before you replace it.