Challenge with optimization on MT4 platform

Hi there,

My EA takes external parameters type “long”. I was trying to run optimization and realized that I cannot optimize this type of parameter. It does not allow me to select this parameter for optimization. Interestingly, “int” type parameters can be used for optimization.

Is there a way to make “long” parameters enabled for optimization?

Any advice would be greatly appreciated.


try double :slight_smile:

I eventually converted it to int. Works fine, but I like to avoid type casting, if possible.